[TEST] - Telstra outage affecting all customers in Perth

Incident Report for Toyota Halo

Resolved

This incident has been resolved.
Posted Jul 06, 2020 - 15:03 AWST

Investigating

We are currently investigating this issue.
Posted Jul 06, 2020 - 15:02 AWST
This incident affected: Cellular Network.