All impacted Multi-Brand devices are back online. All buffered data has been uploaded, and the devices are showing up-to-date event and location information.
Note: Correction to impacted device count: 4x instead of 5x.
Posted May 20, 2026 - 15:16 AWST
Monitoring
Our team have identified the cause of the connectivity issue and has completed remediation. We are now seeing devices reconnect to the cellular network and come back online in the Rand Platform, and we are monitoring for the same in Toyota Halo. As devices reconnect, they will upload all historical data first before displaying an up-to-date event date/time and location.
Our team is actively monitoring all impacted devices as they reconnect to ensure that there are no further issues.
Posted May 20, 2026 - 12:49 AWST
Investigating
We are experiencing a major device connectivity outage for the GX6 device in Australia. This is currently impacting all Multi-Brand devices connected to Toyota Halo (x5 installed units). We are investigating this high-priority issue and have escalated it to our cellular network provider for further support. At this time, we believe the issue is due to cellular connectivity problems, and it is not a device-level or platform-side issue.
We will post further updates as our team and partners progress with identifying and resolving this issue.
Note: This outage is only impacting GX6 devices. All other device types are operational and unaffected.
Posted May 20, 2026 - 11:10 AWST
This incident affected: Multi-Brand Device Connectivity.